Ford F150 EcoBoost Owners Welcomes You!

Jump to content

Custom Search





Advertise here and reach the F150 Ecoboost community. Click here to find out more.




Ford F150 EcoBoost Forum


Sign In  Log in with Facebook

Create Account
Ford F150 EcoBoost Forum welcomes you to our community! Like most online communities, you must register to post, but don't worry this is a simple free process that requires minimal information for you to signup. By becoming a member, you'll enjoy these benefits and more:

Receive special discount offers on apparel, parts and merchandise!
• Start new topics and reply to others
• Subscribe to topics and forums to get email updates
• Get your own profile page and make new friends
• Send personal messages to other members
• Post your photos to the gallery
• View fewer ads. . .more


Posted Image
 
Guest Message by DevFuse

F150 EcoBoost Apparel


F150 EcoBoost Hat


F150 EcoBoost Key Chain


F150 EcoBoost Shirt




F150 EB Exhaust

Shop For More Here

Photo

Ford can't tell me what is wrong with my new truck


  • Please log in to reply
5 replies to this topic

#1 ecoboost mike

ecoboost mike

    New Member

  • F150 EB Member
  • Pip
  • 8 posts
  • LocationDeland Fl
  • Current Vehicle:2011 F150 lariat 4x4 ecoboost

Posted 22 September 2011 - 02:19 PM

Purchased a 2011 Ecoboost 4x4 lariat in May..Everything I wanted in my dream truck..In June I started having problems with the AC blowing Ice Cold air than changing suddenly to warm air and back again.. After being in and out of the dealer a few times, they now have had my truck for 4 days last week and 3 days this week...The dealer says all the computer read outs have been sent to Ford engineering in Detroit, they know there is a problem put don't know what it is...I Asked the dealer to at least have someone from Ford in Detroit call me to a least let me know what is going on and how the plan to find a solution...So far no call...I really don't want to have to go the lemon law route at this point because it is a two tone adobe/Tuxedeo black with navigation system, which is now impossable to replace...

Edited by ecoboost mike, 25 September 2011 - 04:36 PM.








Lose this advertisement by becoming a member. Click here to create a free account.

#2 Ecoboostdieselkiller

Ecoboostdieselkiller

    New Member

  • F150 EB Member
  • Pip
  • 1 posts
  • LocationOrlando, FL
  • Current Vehicle:2011 Ford F150 Lariat Ecoboost

Posted 24 September 2011 - 06:30 PM

I am having the same problem but it lasts for up to five minutes to blow cold again. Also I am having a problem with my tranny down shifting very violently. I am taking it in this week and I will let you know what they say to me..

#3 ecoboost mike

ecoboost mike

    New Member

  • F150 EB Member
  • Pip
  • 8 posts
  • LocationDeland Fl
  • Current Vehicle:2011 F150 lariat 4x4 ecoboost

Posted 25 September 2011 - 04:26 PM

I am having the same problem but it lasts for up to five minutes to blow cold again. Also I am having a problem with my tranny down shifting very violently. I am taking it in this week and I will let you know what they say to me..

sent you a message with my email address.......

#4 ecoboost mike

ecoboost mike

    New Member

  • F150 EB Member
  • Pip
  • 8 posts
  • LocationDeland Fl
  • Current Vehicle:2011 F150 lariat 4x4 ecoboost

Posted 27 September 2011 - 04:20 PM

Truck went back to the dealer again today..Problem starting all over again..I was really hoping that the problem was finally fixed..Worked well all weekend and started again today.

#5 ecoboost mike

ecoboost mike

    New Member

  • F150 EB Member
  • Pip
  • 8 posts
  • LocationDeland Fl
  • Current Vehicle:2011 F150 lariat 4x4 ecoboost

Posted 28 September 2011 - 11:24 AM

Ok , they have had my truck 24 hours now..ford corporate also knows its back, am I expecting too much for a fun call to at least update as to what is going on..Even a we still don't know yet is better than nothing.

#6 EBinMT

EBinMT

    New Member

  • F150 EB Member
  • Pip
  • 14 posts
  • LocationEastern Montana
  • Current Vehicle:'11 F150 XLT S.Crew LWB 4x4 3.31gears

Posted 06 October 2011 - 05:42 PM

My Taurus X's passenger side AC did that every now and then...




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users